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Subject: «Processing of numerical information, editing formulas and creation of charts in plate editors» 

Purpose: Repeat the basic concepts of Excel spreadsheet, create the ability to enter and edit data, use various types of addressing when solving problems, generate skills to calculate the values of functions to plot functions.
Objectives
After completing this lesson, you’ll be able to do the following tasks:
Discover MS Excel Start MS Excel 
Explore the Excel screen. 
Activities
Execute the following tasks:
1. Turn on your Computer. 
1. Find MS Excel program. 
1. Start MS Excel. 
1. Observe the different elements of the Excel screen 
1. Describe what you see. 
1. Compare the window of MS Excel with the MS Word window. 
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I. Getting Started
Getting started with Excel 2007 you will notice that there are many similar features to previous versions. You will also notice that there are many new features that you’ll be able to utilize. There are three features that are fixed in Office 2007: the Microsoft Office Button, the Quick Access Toolbar, and the Ribbon. The function of these features will be more fully explored below.
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I.1 Spreadsheets
A spreadsheet is an electronic document that stores various types of data. There are vertical columns and horizontal rows. A cell is where the column and row intersect. A cell can contain data and can be used in calculations of data within the spreadsheet. An Excel spreadsheet can contain workbooks and worksheets. The workbook is the holder for related worksheets.

a) Microsoft Office Button
The Microsoft Office Button performs many of the functions that were located in the File menu of older versions of Excel. This button allows you to create a new workbook, Open an existing workbook, save and save as, print, send, or close.
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b) Ribbon
The ribbon is the panel at the top portion of the document It has seven tabs: Home, Insert, Page Layouts, Formulas, Data, Review, and View. Each tab is divided into groups. The groups are logical collections of features designed to perform function that you will utilize in developing or editing your Excel spreadsheets.
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Commonly utilized features are displayed on the Ribbon. To view additional features within each group, click the arrow at the bottom right corner of each group.
1. Tabs
Home: Clipboard, Fonts, Alignment, Number, Styles, Cells, Editing
Insert: Tables, Illustrations, Charts, Links, Text
Page Layouts: Themes, Page Setup, Scale to Fit, Sheet Options, Arrange
Formulas: Function Library, Defined Names, Formula Auditing, Calculation
Data: Get External Data, Connections, Sort & Filter, Data Tools, Outline
Review: Proofing, Comments, Changes
View: Workbook Views, Show/Hide, Zoom, Window, Macros





1. [image: ]Data manipulation 

0. Select Data 
To select a cell or data to be copied or cut:
· Click the cell 



· Click and drag the cursor to select many cells in a range 
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Select a Row or Column; To select a row or column click on the row or column header.
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b) Copy and Paste
To copy and paste data:

· Select the cell(s) that you wish to copy 
· On the Clipboard group of the Home tab, click Copy 
· Select the cell(s) where you would like to copy the data 
· On the Clipboard group of the Home tab, click Paste 
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c) Cut and Paste
To cut and paste data:
· Select the cell(s) that you wish to copy 
· On the Clipboard group of the Home tab, click Cut 
· Select the cell(s) where you would like to copy the data 
· On the Clipboard group of the Home tab, click Paste 
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d) Undo and Redo
To undo or redo your most recent actions:

· On the Quick Access Toolbar 
· Click Undo or Redo 

e) Auto Fill
[image: ]The Auto Fill feature fills cell data or series of data in a worksheet into a selected range of cells. If you want the same data copied into the other cells, you only need to complete one cell. If you want to have a series of data (for example, days of the week) fill in the first two cells in the series and then use the auto fill feature. To use the Auto Fill feature:

· Click the Fill Handle 
· Drag the Fill Handle to complete the cells 



1. Working with a Workbook 

0. Create a Workbook 
To create a new Workbook:

· Click the Microsoft Office button 
· [image: ]Click New 
· Choose Blank Document 
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If you want to create a new document from a template, explore the templates and choose one that fits your needs.
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b) Save a Workbook
When you save a workbook, you have two choices: Save or Save As.
To save a document:
· Click the Microsoft Office Button 
· Click Save 
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You may need to use the Save As feature when you need to save a workbook under a different name or to save it for earlier versions of Excel. Remember that older versions of Excel will not be able to open an Excel 2007 worksheet unless you save it as an Excel 97‐2003 Format. To use the Save As feature:

· Click the Microsoft Office Button 
· Click Save As 
· Type in the name for the Workbook 
· In the Save as Type box, we advise you to choose Excel 972003 Workbook, for the 
title bar, letting you know the file was created in an earlier, but recognizable version of the program. If you are working with others who are not using the newest version of the software, you can avoid possible incompatibility problems by saving your file in an earlier format.
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c) Open a Workbook
To open an existing workbook:
· Click the Microsoft Office Button 
· Click Open 
· Browse to the workbook 
· Click the title of the workbook 
· Click Open 
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Excel allows you to move, copy, and paste cells and cell content through cutting and pasting or copying and pasting.

IV. Formatting a Worksheet
a) Convert Text to Columns
Sometimes you will want to split data in one cell into two or more cells. You can do this easily by utilizing the Convert Text to Columns Wizard.
· Highlight the column in which you wish to split the data 
· Click the Text to Columns button on the Data tab 
· Click Delimited if you have a comma or tab separating the data, or click fixed widths to set the data separation at a specific size. 
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b) Modify Fonts
Modifying fonts in Excel will allow you to emphasize titles and headings. To modify a font:

· Select the cell or cells that you would like the font applied 
· On the Font group on the Home tab, choose the font type, size, bold, italics, underline, or color 
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c) Format Cells Dialog Box
In Excel, you can also apply specific formatting to a cell. To apply formatting to a cell or group of cells:
· Select the cell or cells that will have the formatting 
· Click the Dialog Box arrow on the Alignment group of the Home tab 
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There are several tabs on this dialog box that allow you to modify properties of the cell or cells.

Number: Allows for the display of different number types and decimal places Alignment: Allows for the horizontal and vertical alignment of text, wrap text, shrink text, merge cells and the direction of the text.
Font: Allows for control of font, font style, size, color, and additional features Border: Border styles and colors

Fill: Cell fills colors and styles

Protection: the cell protection attribute is set to Locked, When a user attempts to change the contents of a locked cell an error message is displayed.
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d) Add Borders and Colors to Cells
Borders and colors can be added to cells manually or through the use of styles. To add borders manually:

· Click the Borders drop down menu on the Font group of the Home tab 

· Choose the appropriate border 
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[bookmark: page57]Exercises
1. Adjust all titles in center. 
1. Merge cells of the first line of titles. 
1. Entering all data. 
1. Adjust column width and rows heigth. 
1. Hide the percentage column. 
1. Create worksheets of each ditricts. 

TAPPING THE POWER OF EXCEL
Objectives
After completing this lesson, you’ll be able to do the following tasks:

Create and revise formulas. 
Understand absolute and relative references. Add functions to formulas. 
Sort and filter data. 
Create and modify charts, graphics, and diagrams. 
Activities
1. Create this list of students and fill their respective marks in different courses, calculate the total and percentage for each student. 
1. Display the first decimal of all points. 

1. Display students in alphabetic order. 
1. Display only students who have greater than 50 in math and greater than 15 in physics. 
0. Open the workbook “graphics” located in excel exercise folder on your desktop. 
1. Create a chart in sectors that indicates clients by level of education according to the following table. 
1. Title the chart as “clients by level of education”. 
1. Put the chart on a new worksheet named" chart movement ".
1. Save the modifications. 

CLIENTS BY LEVEL OF EDUCATION
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0. Excel Formulas 
A formula is a set of mathematical instructions that can be used in Excel to perform calculations. Formals are started in the formula box with an = sign.
There are many elements to excel formula.

References: The cell or range of cells that you want to use in your calculation
Operators: Symbols (+, ‐, *, /, etc.) that specify the calculation to be performed
Constants: Numbers or text values that do not change
Functions: Predefined formulas in Excel

To create a basic formula in Excel:

· Select the cell for the formula 
· Type = (the equal sign) and the formula 
· Click Enter 
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[bookmark: page81]b) Calculate with Functions
A function is a built in formula in Excel. A function has a name and arguments (the mathematical function) in parentheses. Common functions in Excel:

Sum: Adds all cells in the argument
Average: Calculates the average of the cells in the  argument 
Min: Finds the minimum value
Max: Finds the maximum value
Count: Finds the number of cells that contain a numerical value within a range of the argument

To calculate a function:
· Click the cell where you want the function applied 
· Click the Insert Function button from formula tab 
· Choose the function 
· Click OK 
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· Complete the Number 1 box with the first cell in the range that you want calculated 
· Complete the Number 2 box with the last cell in the range that you want calculated 
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c) Function Library
The function library is a large group of functions on the Formula Tab of the Ribbon. These functions include:

AutoSum: Easily calculates the sum of a range
Recently Used: All recently used functions
Financial: Accrued interest, cash flow return rates and additional financial functions
Logical: And, If, True, False, etc.
Text: Text based functions
Date & Time: Functions calculated on date and time
Math & Trig: Mathematical Functions

Help: you can use the help icon located to the top right of tab, to get more explanations for different functions you can use.

[bookmark: page85]d) Relative, Absolute and Mixed References
Calling cells by just their column and row labels (such as "A1") is called relative referencing. When a formula contains relative referencing and it is copied from one cell to another, Excel does not create an exact copy of the formula. It will change cell addresses relative to the row and column they are moved to. For example, if a simple addition formula in cell C1 "=(A1+B1)" is copied to cell C2, the formula would change to "=(A2+B2)" to reflect the new row. To prevent this change, cells must be called by absolute referencing and this is accomplished by placing dollar signs "$" within the cell addresses in the formula. Continuing the previous example, the formula in cell C1 would read "=($A$1+$B$1)" if the value of cell C2 should be the sum of cells A1 and B1. Both the column and row of both cells are absolute and will not change when copied. Mixed referencing can also be used where only the row or column fixed. For example, in the formula "=(A$1+$B2)", the row of cell A1 is fixed and the column of cell B2 is fixed.

e) Linking Worksheets
You may want to use the value from a cell in another worksheet within the same workbook in a formula. For example, the value of cell A1 in the current worksheet and cell A2 in the second worksheet can be added using the format "sheetname!celladdress". The formula for this example would be "=A1+Sheet2!A2" where the value of cell A1 in the current worksheet is added to the value of cell A2 in the worksheet named "Sheet2".
Sorting and Filtering allow you to manipulate data in a worksheet based on given set of criteria.
II.  Sort and Filter

Sorting and Filtering allow you to manipulate data in a worksheet based on given set of criteria.
a) Basic Sorts
To execute a basic descending or ascending sort based on one column:
· Highlight the cells that will be sorted 
· Click the Sort & Filter button on the Home tab 
· Click the Sort Ascending (A‐Z) button or Sort Descending (Z‐A) button 
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[bookmark: page87]b) Custom Sorts
To sort on the basis of more than one column:

· Click the Sort & Filter button on the Home tab 
· Click custom sort 
· Choose which column you want to sort by first 
· Click Add Level 
· Choose the next column you want to sort 
· Click OK 
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c) Filtering
Filtering allows you to display only data that meets certain criteria. To filter:

· Click the column or columns that contain the data you wish to filter 
· On the Home tab, click on Sort & Filter 
· Click Filter button 
· Click the Arrow at the bottom of the first cell 
· Click the Text Filter 
· Click the Words you wish to Filter 
· To clear the filter click the Sort & Filter button 
· Click Clear 
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1. Graphics 
0. Adding a Picture 
To add a picture:
· Click the Insert tab 
· Click the Picture button 
· Browse to the picture from your files 
· Click the name of the picture 
· Click Insert 
· To move the graphic, click it and drag it to where you want it 
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b) Adding Clip Art
To add Clip Art:
· Click the Insert tab 
· Click the Clip Art button 
· Search for the clip art using the search Clip Art dialog box 
· Click the clip art 
· To move the graphic, click it and drag it to where you want it 
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c) Editing Pictures and Clip Art
When you add a graphic to the worksheet, an additional tab appears on the Ribbon. The Format tab allows you to format the pictures and graphics. This tab has four groups:

Adjust: Controls the picture brightness, contrast, and colors
Picture Style: Allows you to place a frame or border around the picture and add effects
Arrange: Controls the alignment and rotation of the picture
Size: Cropping and size of graphic

· [bookmark: page95]Click the Worksheet 
· Drag the cursor to expand the Shape 
[bookmark: page97]To format the shapes:
· Click the Shape 
· Click the Format tab 
e) Adding SmartArt
SmartArt is a feature in Office 2007 that allows you to choose from a variety of graphics, including flow charts, lists, cycles, and processes. To add SmartArt:

· Click the Insert tab 
· Click the SmartArt button 
· Click the SmartArt you choose 
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· Select the Smart Art 
· Drag it to the desired location in the worksheet 

[bookmark: page99]To format the SmartArt:

· Select the SmartArt 
· Click either the Design or the Format tab 
· Click the SmartArt to add text and pictures. 
IV. Charts
Charts allow you to present information contained in the worksheet in a graphic format. Excel offers many types of charts including: Column, Line, Pie, Bar, Area, Scatter and more. To view the charts available click the Insert Tab on the Ribbon.
a) Create a Chart
To create a chart:

· Select the cells that contain the data you want to use in the chart 
· Click the Insert tab on the Ribbon 
· Click the type of Chart you want to create 

[bookmark: page101]b) Modify a Chart
Once you have created a chart you can do several things to modify the chart.
To move the chart:
· Click the Chart and Drag it another location on the same worksheet, or 
· Click the Move Chart button on the Design tab 
· Choose the desired location (either a new sheet or a current sheet in the workbook) 
To change the data included in the chart:
· Click the Chart 
· Click the Select Data button on the Design tab 

[bookmark: page103]To reverse which data are displayed in the rows and columns:
· Click the Chart 
· Click the Switch Row/Column button on the Design tab 

To modify the labels and titles:
· Click the Chart 
· On the Layout tab, click the Chart Title or the Data Labels button 
· Change the Title and click Enter 
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You are a secretary of a high school. The head teacher asks you to make a list of staff payment and save it as" payment list"
1. Fill:
1. The column "Gross salary” 
1. The column "medical Care", if it is 15% of gross salary in Frw. 
1. The column" TPR”, if the tax is 30% of the gross salary. 
1. The column of FARG, if it is 1% of the G.salary. 
1. The column”CSR”, if it is 3% of the gross salary minus the transport (add the column of transport and give them 7000 frw for all) 
d) The column of "Net salary" if net salary is equal to Gross salary minus medical care minus tax and FARG.

Control questions:
1. What is a spreadsheet?
2. What forms autofill you know?
3. What is the name of the program MS Excel document?
4. What types of addressing you know? How do they differ from each other?
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